[Vitrine] Can't import demo

  • In Progress
    Posted in: VITRINE  

  • Member
    Web Dev
    April 10, 2018 at 9:29 PM #16090

    Like many users, I need the plugin SSH SFTP Updater Support to allow WordPress to install/update plugins through SFTP, without it the webserver will not be able to write to server files and folders.

    I get this error after clicking on the Import Demo button:

    [code title=""]Fatal error: Uncaught Error: Call to a member function get() on boolean in /var/www/html/wp-content/plugins/ssh-sftp-updater-support/class-wp-filesystem-ssh2.php:128 Stack trace: #0 /var/www/html/wp-content/themes/vitrine/lib/demo-installer.php(95): WP_Filesystem_SSH2->get_contents('/var/www/html/w...') #1 /var/www/html/wp-content/themes/vitrine/lib/demo-installer.php(675): Epico_Importer->importer_start() #2 /var/www/html/wp-includes/class-wp-hook.php(286): Epico_Importer->dispatch('') #3 /var/www/html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #4 /var/www/html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /var/www/html/wp-admin/admin.php(224): do_action('appearance_page...') #6 /var/www/html/wp-admin/themes.php(10): require_once('/var/www/html/w...') #7 {main} thrown in /var/www/html/wp-content/plugins/ssh-sftp-updater-support/class-wp-filesystem-ssh2.php on line 128[/code]

    Can you provide an xml I can use, or another method, instead?

    Sorry, this forum is for verified users only. Please Login or Register to continue

Comments are closed.